Jump to content
IHC-User.dk
  • 0
Sign in to follow this  
Peter Vistesen

Input samplings tid ..

Question

Jeg er ved at lave en dims der sider uden på en elmåler, som sidder ved Led for forbrug, således jeg kan få forbrugaflæsning i IHC, uden at skulle betale 200 kr pr år, til mit elselvskab for at får lov til at lave en elektrisk kobling til forbrugs outputtet.Men hvor hurtigt samples et input ? altså hvor langt skal et input minimum være for at IHC'en ser den som høj?

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Hej Efter den har været på ca 80 mS, er den vistnok nede omkring 30 mS hvis controlleren har den nyeste firmware. Har selv bøvlet med for hurtige pulser fra SO udgangen på el-måleren. Men det er løst med den nye firmware.Michael

Share this post


Link to post
Share on other sites
  • 0
Det lyder som et spændende projekt.Du skulle vel ikke have et diagram på den 'dims' du er ved at lave?Hilsen Ulrich
Prøv at google: ARDUINO LED power meter sensorog du vil få nogle eksempler på hvordan det kan laves.En simpel fotodiode eller LDR modstand + evt et kredsløb der tilpasser til anden forsyningsspænding og/eller input end de 5v som der oftest er tale om.

Share this post


Link to post
Share on other sites
  • 0
Har lige flikket dette sammen af nogle forhåndenværende komponenter og testet at det faktisk virker hvis det tilslutes en indgang på et 24V Input modul (3ma):[attachment=1371]LDR.JPG[/attachment]Ellers er her lidt mere info:http://togglezero.blogspot.com/2007/11/ldr-light-dependent-resistors.html
Virker det ved de relativt små leds der sidder på elmålerens?

Share this post


Link to post
Share on other sites
  • 0
Jeg har sådan en dims ;-)Type-F www.zigza.dk
Cool - men virker den på denne El måler ?Tænker på at led ser meget lille ud og med et relativt lavt lys nivea....http://www.google.com/imgres?imgurl=http://ing.dk/modules/xphoto/cache/56/26456_650_550_0_0_0_0.jpg&imgrefurl=http://ing.dk/artikel/113478-deltag-i-ingenioeren-live-skal-fremtidens-elmaaler-aflaese-hvert-minut&usg=__3FATcDeSjD8a7Fu2I3lqOwHNK7g=&h=527&w=650&sz=189&hl=en&start=0&zoom=1&tbnid=MYKyej-DTp_z5M:&tbnh=119&tbnw=147&prev=/images%3Fq%3Delm%25C3%25A5ler%2Benergimidt%26um%3D1%26hl%3Den%26sa%3DN%26rls%3Dcom.microsoft:en-US:IE-SearchBox%26rlz%3D1I7GGLL_en%26biw%3D1112%26bih%3D807%26tbs%3Disch:1&um=1&itbs=1&iact=rc&dur=328&ei=wS8sTfbHOIb24Qat8czzCA&oei=wS8sTfbHOIb24Qat8czzCA&esq=1&page=1&ndsp=28&ved=1t:429,r:15,s:0&tx=112&ty=63

Share this post


Link to post
Share on other sites
  • 0

Mon ikke. Mit simple kredsløb er testet på en Kamstrup 382 som også har en rimelig lille gul/grøn diode.Parralelt og lige forfra på 2-5mm afstand er lysstyrken på alle LED faktisk rimelig kraftig.Og et lille fif mht montering er f.eks. at gøre det vha "elefantsnot". Så kan man nemt fastgøre den på en glat og rund overflade og samtidig skærme af for andet lys og dermed øge fælsomheden.

Share this post


Link to post
Share on other sites
  • 0

Låner lige jeres tråd, da jeg har meget aktuelle spørgsmål til emnet.Efter at have læst diverse tråde her på siden, har jeg købt den optiske sensor F fra Zigza, og har monteret den på netop sådan en Echelon elmåler, som xang72 linker til (fra EnergiMidt).Sensoren virker fint, når jeg f.eks. holder hånden for den osv. - men den aktiveres ikke når jeg sætter den på lysdioden på måleren. Jeg har brugt sådan noget vindueslisteskumklisterbånd(eller hvad det nu hedder), og gaffa udenpå, for at sikre mod falsk lys.Det skal siges at jeg har sat den på et input 24/24 - da jeg ikke har et input 24/3 i min installation - tror i det kunne gøre en forskel.Jeg har lige opdateret firmwaren til 2,7,144 - da jeg kunne læse her at ældre fw versioner kunne have problemmer med at opfatte de korte pulser.Når jeg logger ind i serviceview - har min kontroller denne fejl i loggen :2011.12.13 02:19:04 Fatal DEBUG: VITAL THREAD 'System time scheduler' DIED!Kan det mon have noget med dette at gøre (Sensoren var ikke monteret den 13/12) - men ved ikke om fejlmeldingen kunne betyde at min controller ikke er helt "rask".

Share this post


Link to post
Share on other sites
  • 0
Låner lige jeres tråd' date=' da jeg har meget aktuelle spørgsmål til emnet.Efter at have læst diverse tråde her på siden, har jeg købt den optiske sensor F fra Zigza, og har monteret den på netop sådan en Echelon elmåler, som xang72 linker til (fra EnergiMidt).Sensoren virker fint, når jeg f.eks. holder hånden for den osv. - men den aktiveres ikke når jeg sætter den på lysdioden på måleren. Jeg har brugt sådan noget vindueslisteskumklisterbånd(eller hvad det nu hedder), og gaffa udenpå, for at sikre mod falsk lys.Det skal siges at jeg har sat den på et input 24/24 - da jeg ikke har et input 24/3 i min installation - tror i det kunne gøre en forskel.Jeg har lige opdateret firmwaren til 2,7,144 - da jeg kunne læse her at ældre fw versioner kunne have problemmer med at opfatte de korte pulser.Når jeg logger ind i serviceview - har min kontroller denne fejl i loggen :2011.12.13 02:19:04 Fatal DEBUG: VITAL THREAD 'System time scheduler' DIED!Kan det mon have noget med dette at gøre (Sensoren var ikke monteret den 13/12) - men ved ikke om fejlmeldingen kunne betyde at min controller ikke er helt "rask".[/quote'] Der er da i hvert fald en i denne tråd, som først fik det til at virke efter montage på 24/3 input!

Share this post


Link to post
Share on other sites
  • 0

OK - jeg har bestilt et 3ma modul - så må vi håbe det er det der skal til.Har lige forsøgt med at klistre den optiske sensor på den blinkende status LED på selv IHC controlleren - det kan den fint detekterer. Men det er jo også længere blink - og noget kraftigere lys.Men alt i alt kan det jo godt give mening at et 3ma modul er hurtigere til at nå trigger niveau end et 24ma - vi må se.Vil alligevel have lavet lidt simpel tyverialarm - så skal nok få brugt 3ma modulet til det om alle omstændigheder.

Share this post


Link to post
Share on other sites
  • 0

Jeg har her til aften monteret et 24/3 inputmodul - og sat Type F sensoren til den.Den aktiveres fint a diverse lyskilder - men ikke af den røde diode på Echolen El-måleren.Jeg har så derefter klippet modstanden under krypeflexen på sensoren - det får den heller ikke til at virke.Så lige nu må jeg konstaterer at enten er pulsen for kort, eller også er lyset for svagt.Nogle der har ideer til afhjælpning ?

Share this post


Link to post
Share on other sites
  • 0
Jeg har her til aften monteret et 24/2 inputmodul - og sat Type F sensoren til den.Den aktiveres fint a diverse lyskilder - men ikke af den røde diode på Echolen El-måleren.Jeg har så derefter klippet modstanden under krypeflexen på sensoren - det får den heller ikke til at virke.Så lige nu må jeg konstaterer at enten er pulsen for kort' date=' eller også er lyset for svagt.Nogle der har ideer til afhjælpning ?[/quote']Har du haft dækslet af din måler og set om den har en S0 udgang?

Share this post


Link to post
Share on other sites
  • 0

@mwiDer er ikke nogen mulighed for at tage dækslet af uden at bryde plumberingen.@klausDen er altid Off.Så hvis du tænker på falsk lys - så er det ikke problemmet.Jeg har også afskærmet den rigtig godt med noget skumliste med et firkantet hul kun lige til sensor øjet.Ved du om den sensor du bruger kunne være mindre følsom over for rødt lys (høj bølgelængde) ?Sensoren virker jo fint, når jeg tester med f.eks. den grønne live diode på IHC controlleren. Jeg har bestilt en LDR m.v. på Ebay - så vil jeg prøve at bygge det lille Kredsløb som Lars skitsere tidligere i tråden.

Share this post


Link to post
Share on other sites
  • 0
Så lige nu må jeg konstaterer at enten er pulsen for kort' date=' eller også er lyset for svagt.[/quote']I forbindelse med et andet projekt jeg har gang i, fortalte en af mine venner som er elektronik ingeniør om et oneshot relæ, som kan bruges til at forlænge tiden på en puls, hvis den er for kort, hvilket er tilfældet i det projekt. Hvor man får sådan et relæ, og hvordan det skal bygges ind i opstillingen ved jeg ikke. Det er vi ikke nået til endnu, da der er en del andre forhindringer som skal overvindes først.Jeg har hørt om en som har løst problemet ved at flytte LDR sensoren lidt væk fra dioden, med et lille rør, hvor der ikke kan slippe falsk lys ind. Hvordan det forstærker lyset ved jeg ikke, men jeg kan forstille mig at det løser problemet med genskin og lysspredning i glasset på måleren.

Share this post


Link to post
Share on other sites
  • 0

Så har jeg fået samlet det lille kredsløb af en LDR, BC557 og 10k trimpot på noget universal-print, og derefter klistret det på måleren med gaffa-tape.Og med det tilsluttet til mit 24/3 input modul, så ser det nu ud til at virke - i hvert fald lige umiddelbart.Så til andre med denne Echelon måler - så må det være vejen frem.Tak for inputs til jer alle sammen.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

Privacy Policy og We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.