Jump to content
IHC-User.dk

Jakob Hauerslev

Members
  • Content Count

    42
  • Joined

  • Last visited

  • Days Won

    1

Jakob Hauerslev last won the day on December 16 2018

Jakob Hauerslev had the most liked content!

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Gem projektet lokalt på din computer, så kan du altid uploade den til controlleren igen. Så kan du bare kalde dem backup, og så ellers kaste dig ud i at bruge visual. Filen kommer til at slutte på .vis Dokumentationen er hvilke ud- og indgange der bruges til forskellige enheder i din installation. (Altså dit hardware-setup)
  2. Pauli was completely right - my binding is an outdated one, and yes, I am using 2.4 stable. How do I get the updated .jar file? The only one I can find is one dated october 2018 https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/binding/org.openhab.binding.ihc/2.4.0-SNAPSHOT/ Once again, thanks for helping me out
  3. Problemet er at jeg også troede at det var seneste version jeg havde fundet frem, men det var det så ikke. Men pludselig giver det mening at den ikke kan finde ip-adressen, når jeg har rodet rundt i versionerne.
  4. Tried with "elko" but same fault. I will try pauils hint when i get home :-)
  5. Hi Makes sense - it was working with the build-in binding in 2.5 milestone, but now i am at 2.4 stable. I used a link in your update post - think it was build october 2018 (not at home yet) - is that the correct binding? Thanks!
  6. Problemet er at den slet ikke fanger IHC'en - den initialiserer ikke "HANDLER_MISSING" - når man ser indstillingerne på den i PaperIU, så står alt som det skal, men adressen på IHC er der ikke. Så det er lidt som om at den ikke fatter at læse ip-adressen. Jeg ved virkelig ikke hvad jeg gør galt, og det irriterer mig grænseløst, at jeg ikke kan få det til at virke, for det har virket, og det virker også fint med Velux og Chromecast....
  7. Jeg er begyndt på det, da jeg lavede så meget kludder i en installation, at jeg skulle starte forfra, og så var det ekstremt irriterende at skulle til at tilføje bl.a. temperatur setpoint til alle rum igen via ny channel i paperui - meget nemmere med en fil der bare kunne kopieres ind i things-mappen! Jeg installerer bindingen, og lægger så things filen ind i things-mappen - og så kommer den der fejl i loggen. Men ihc'en kan sagtens tilføjes fra paperui og bruges uden særskilt things-fil, så det er ikke oplysningerne om forbindelsen til ihc'en der er forkerte i filen - men hvad er det så? Jeg ville jo helst bare bruge autochannels til det meste, og så selv lave channels i en fil, til de ting hvor de ellers skulle oprettes channels via paperuøi - jeg mener også at have læst at andre gør sådan.
  8. Igen - tak for hjælpen! Nu har jeg så, efter jeres opfordringer, begyndt at lave things-filer. Det virker fint med Velux, men ikke med IHC: 2019-12-09 13:58:08.028 [hingStatusInfoChangedEvent] - 'ihc:controller:1' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_CONFIGURATION_PENDING) Jeg bruger følgende i things-filen:' ihc:controller:1 [ hostname="192.168.1.10", username="jakob", password="xxxx", timeout=5000, loadProjectFile=true, createChannelsAutomatically=true ] Den kan fint sættes op med PaperUI, og så er der hul igennem til den, men det var jo ikke meningen med at lave en things-fil. Anyone? :-)
  9. Eksempel hvor mit kodetastatur til- og afkobler alarmen (to pulser, som selv "kipper tilbage" 2019-12-07 09:32:23.755 [vent.ItemStateChangedEvent] - Alarm_io changed from OFF to ON 2019-12-07 09:32:23.957 [vent.ItemStateChangedEvent] - Alarm_io changed from ON to OFF 2019-12-07 09:32:27.088 [vent.ItemStateChangedEvent] - Alarm_io changed from OFF to ON 2019-12-07 09:32:27.344 [vent.ItemStateChangedEvent] - Alarm_io changed from ON to OFF Eksempel hvor Google Home til- og afkobler alarmen (fire tryk på tænd/sluk i app - den kipper ikke selv tilbage) 2019-12-07 09:33:14.713 [ome.event.ItemCommandEvent] - Item 'Alarm_io' received command ON 2019-12-07 09:33:14.742 [nt.ItemStatePredictedEvent] - Alarm_io predicted to become ON 2019-12-07 09:33:14.758 [vent.ItemStateChangedEvent] - Alarm_io changed from OFF to ON 2019-12-07 09:33:17.636 [ome.event.ItemCommandEvent] - Item 'Alarm_io' received command OFF 2019-12-07 09:33:17.674 [nt.ItemStatePredictedEvent] - Alarm_io predicted to become OFF 2019-12-07 09:33:17.695 [vent.ItemStateChangedEvent] - Alarm_io changed from ON to OFF 2019-12-07 09:33:21.210 [ome.event.ItemCommandEvent] - Item 'Alarm_io' received command ON 2019-12-07 09:33:21.252 [nt.ItemStatePredictedEvent] - Alarm_io predicted to become ON 2019-12-07 09:33:21.262 [vent.ItemStateChangedEvent] - Alarm_io changed from OFF to ON 2019-12-07 09:33:23.245 [ome.event.ItemCommandEvent] - Item 'Alarm_io' received command OFF 2019-12-07 09:33:23.283 [nt.ItemStatePredictedEvent] - Alarm_io predicted to become OFF 2019-12-07 09:33:23.304 [vent.ItemStateChangedEvent] - Alarm_io changed from ON to OFF Er jeg ude i at skulle lave en push-button, og hvordan i alverden laver man den? Som du kan se i loggen, så pulser appen samme steder i fb som mit kodetastatur - den kipper bare ikke - altså kipfunktionen bliver kun påvirket når appen pulser "ON" - "OFF" påvirker slet ikke fb'en.
  10. Hej Så er mit projekt nået til alarmen på min installation - efter vellykket tilslutning af velux KLF200 (tak for hjælpen til nogle stykker herinde!) Jeg kan ikke få min switch i google home til at agere kip-funktion - selvom jeg har angivet pulsewidth=100 på min channel. Things: Type switch : talarm_status "Alarm tilkoblet" [resourceId=8483602, direction="readonly"] Type switch : talarm_switch "Alarm switch" [resourceId=8412690, pulsewidth=100] Items: Switch Alarm_io "Alarm on/off" (Bryggers)["Switchable"]{channel="ihc:controller:1:talarm_switch", channel="ihc:controller:1:talarm_status"} Jeg har knyttet "talarm_switch" til puls-udgangen fra mit kodetastatur, og "talarm_status" til "Totalalarm tilkoblet" i funktionsblokken. Hvad er det at jeg gør forkert - switchen i google home skal trykkes fire gange for at tænde og slukke, ikke to gange (kip) ???
  11. Den med =1 var et forsøg der åbenbart gik galt. Lavede ændringen, og så virkede det - det var så fordi telestaten kaldte på varme, og intet andet... Jeg hopper på rule-vognen indtil den switchtype kommer - for det ser da ud til at han er med på din plan :-) ... Og tak for arbejdet med den rule - jeg har for nyligt fået mine chromecast audio til at tænde og slukke mine forstærkere når de henholdsvis er i play og pause, bl.a. ud fra nogle af de eksempler du har lavet her, og så selvfølgelig ud fra dokumentationen - det der openhab er nu ok når man lærer at tænke openhab'sk ;-)
  12. Det er så fordi at man nu SKAL bruge en heating/cooling-mode, og at den skal være en værdi der er =1 (da den i funktionsblokken kun har en mode når den er aktiv, som så gør at man ikke kan justere setpunkt når den er 0). Så nu har jeg linket den til mit backupmodul 24V, der altid er on. Til inspiration: Group g_Badtermostat "Gulvvarme lille bad" [ "Thermostat" ] Number Lille_bad_Temp "Lille bad temperatur" (g_Badtermostat) [ "CurrentTemperature" ] {channel="ihc:controller:1:temperature136212"} Number Lille_bad_Setpoint "Lille bad setpoint" (g_Badtermostat) [ "homekit:TargetTemperature" ] {channel="ihc:controller:1:lb_setpoint"} Number Lille_bad_Mode "Lille bad Heating/Cooling Mode" (g_Badtermostat) [ "homekit:HeatingCoolingMode" ] {channel="ihc:controller:1:input114778"} Og da jeg læste op på det, blev jeg opmærksom på at TargetTemperature nu har skiftet navn til homekit:TargetTemperature... Og Kandersen - nu virker det med Nest Hub ! :-)
  13. Er jeg den eneste som nu har ikke-fungerende termostater i min google home app? Den skriver tilstand: ukendt (nede i heating/cooling-mode) og så er slideren bare grå? Jeg mener ikke at have ændret noget - er det kun mig der har det problem? Det er nok gået galt inden for de sidste par uger...
  14. Det var det der var galt - nu er jeg ikke vant til at læse dokumentation, men jeg har godt nok kradset hul i hovedbunden et par gange over den KLF-binding og den tilhørende dokumentation - total forvirring fra min side. Det virker nu hvor jeg fandt den inde i channel-listen, det var der den var gal. jeg manglede ":position" - Dog meldte den en fejl i loggen, som jeg brugte 15 minutter på, men det var så fordi regnsensoren var aktiv og blokerede vinduet... Igen mange tak for hjælpen - jeg generer dig en anden dag hvor der er noget jeg ikke kan få til at virke ;-)
  15. Jeg er begyndt at forsøge med at lave det hele i filer, da jeg godt kan se at det er rigtig smart - men så rykker vi lige et niveau op i sværhedsgrad - men så er det jo godt at vi har så hjælpsomme folk her på forummet :-) velux.things // Definition of Velux bridge velux:klf200:home // Bridge velux:klf200:home [ ipAddress="192.168.1.22", tcpPort=51200, password="velux123" ] { // Velux scenes // Velux IO-homecontrol devices Thing actuator V_Entre [ serial="53:2A:59:5A:11:0E:01:99" ] Thing actuator V_Bad [ serial="53:2A:59:5A:11:12:02:EE" ] ----- velux.items // Velux Actuator channels Rollershutter V_Entre "Velux entre [%d]" { channel="velux:klf200:home:V_Entre" } Jeg har også prøvet at kalde rollershutter channel for velux:actuator:home:V_Entre (da det er det loggen skriver) men den skriver også bare NULL: ==> /var/log/openhab2/events.log <== 2019-11-19 19:22:23.564 [ome.event.ItemCommandEvent] - Item 'V_Entre' received command 38 2019-11-19 19:22:23.587 [nt.ItemStatePredictedEvent] - V_Entre predicted to become NULL Det er sandsynligvis noget simpelt (det håber jeg) :-)
×
×
  • Create New...

Important Information

Privacy Policy og We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.